[renewal] possible solution for black screen loading lag

The usual loading routine proceeds as follows:

  1. “please wait” dialog appears
  2. screen turns black
  3. progress bar counts up from 0% to 100%
  4. loading completes

For some people, the screen may remain black for a significant amount of time. It seems to have gotten much worse after the merge.

This is how we managed to reduce the amount of time spent at the black screen. It made a very noticeable difference for me and a friend; I don’t guarantee that it’ll work for you.

  1. Start Registry Editor. (On Windows Vista and 7, you may have to run the command as Administrator. How to do so is beyond the scope of this guide.)
    step1
  2. In the left pane, navigate to Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Gravity Soft\Ragnarok\SkillUseLevelInfo. If you have 64-bit Windows, go instead to Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Gravity Soft\Ragnarok\SkillUseLevelInfo. (This screenshot is on 32-bit Windows.) It will probably take a while to load.
    step2
  3. Right-click on SkillUseLevelInfo and select “Permissions…”
    step5
  4. Select each entry under “Group or user names” and check all the “Deny” boxes. Finally click “OK.”
    step6
  5. If you see this, choose “Yes.”
    step7
  6. Exit Registry Editor.

That’s it! You’ll lose the ability to remember selected skill levels in the skill window–apparently they default to max level–but I’ve never found that to be useful anyway.

This entry was posted in ragnarok. Bookmark the permalink.

Leave a Reply